Soporte Extendido para PHP

En este artículo encontrarás la información más importante con respecto a nuestro servicio de pago Soporte Extendido para PHP.

¿Qué es el servicio de Soporte Extendido para PHP?

PHP es un lenguaje de programación muy potente que se utiliza para crear páginas web dinámicas. Sistemas de gestión de contenidos (CMS) tan populares como WordPress, Drupal o Joomla! se basan en PHP.

La Communidad PHP publica regularmente versiones actualizadas y optimizadas de PHP y, en cierto momento, deja de prestar soporte a las versiones anteriores. Las versiones más antiguas se quedan obsoletas sin actualizaciones de seguridad, por lo que no deberían seguir usándose.

Para disponer de tiempo suficiente a la hora de actualizar tu versión de PHP, en IONOS te ofrecemos el servicio de Soporte Extendido para PHP. Con este servicio pretendemos garantizar tu presencia online ininterrumpida, así como evitar que tu web sea vulnerable frente a los hackers.

En el marco del Soporte Extendido para PHP, IONOS pone a tu disposición un servicio de protección a través de nuestras infrasestructuras y nuestro equipo experto en seguridad con el fin de garantizar que los agujeros de seguridad se vuelven a cerrar inmediatamente. De este modo, tus proyectos y scripts de PHP permanecerán seguros frente a los ciberataques hasta que decidas pasar a una versión más actual de PHP.

El mantenimiento de las versiones obsoletas de PHP implica un mayor esfuerzo de administración en nuestros sistemas con sus consecuentes gastos. Por eso, este servicio adicional tiene un costo mensual.

¿Qué versiones de PHP se ven afectadas?

La Comunidad PHP ya dejó de prestar soporte para las versiones PHP 4.0, PHP 5.2, PHP5.4, PHP 5.5, PHP 5.6, PHP 7.0, PHP 7.1, PHP 7.2, PHP 7.3 y PHP 7.4 . Por este motivo, desde IONOS solo podemos ofrecerte un soporte para dichas versiones mediante el servicio de Soporte Extendido para PHP.

Por otro lado, lo más recomendable a largo plazo es que utilices una versión de PHP actual. Por ejemplo, la versión PHP 8.2 te permite utilizar las aplicaciones más populares y eficaces sin problemas de compatibilidad.

Información importante para los usuarios de PrestaShop

Las versiones de PrestaShop hasta la 1.7.8 inclusive instaladas a través del App Center IONOS no funcionarán con una versión de PHP superior a 7.4.

Versión de PHP superior a 7.4 con PrestaShop 1.7.8 o inferior Versión de PHP 7.4 o inferior con PrestaShop 1.7.8 o inferior PrestaShop 8 o superior
Acción requerida: Actualiza tu instalación de PrestaShop. PrestaShop 8.0 soporta PHP 8.0 y 8.1 No es necesario realizar ningún cambio en tu instalación de PrestaShop. El mantenimiento de la versión de PHP requiere el Soporte Extendido para PHP, que está disponible por una tarifa a partir de abril de 2023 Se requiere una versión actual de PHP, como 8 o 8.1

Importante: Antes de cualquier acción, haz una copia de seguridad de tus datos del espacio web y de la base de datos MySQL.

Determinar la versión de PrestaShop

Accede al área de administración de tu tienda PrestaShop y haz clic en cualquier elemento de la barra de navegación. Mueve el contenido de la pantalla hasta alcanzar el borde inferior. El número de versión de tu PrestaShop se muestra en el lado izquierdo.

Si PrestaShop 8.0 ya está instalado, haz clic en Grupo de datos: Configuración >Configuración avanzada > Información, en la barra de navegación para mostrar la versión.

Actualizar PrestaShop

PrestaShop es un programa independiente de código abierto para el que IONOS no ofrece soporte directo. Encontrarás información sobre la actualización de PrestaShop aquí (en ingles):

¿Por qué se me factura el servicio de Soporte Extendido para PHP?

Tu espacio web tiene contenidos PHP en una versión antigua para la que ya no se presta soporte. Esto se debe a que, en tu cuenta IONOS, al menos un dominio o subdominio tienen configurada una versión antigua de PHP.

Comprobar y actualizar la versión de PHP

La configuración de tus dominios y subdominios se puede realizar de forma separada. Para saber qué versión de PHP utilizan tus dominios y cómo actualizarla, consulta este artículo.

Actualizaste la versión de PHP, pero se te sigue facturando el servicio de Soporte Extendido

¿Actualizaste la versión de PHP de tus dominios, pero sigues pagando por el servicio de Soporte Extendido?

IONOS incluye una nota relativa a la cancelación de dicho servicio en la configuración de PHP que quizás se ha pasado por alto. Si no necesitas el servicio de Soporte Extendido, debes acceder a tu cuenta IONOS y seleccionar la opción para cancelar servicios adicionales. De lo contrario, también puedes cancelar dicho servicio desde la página de configuración de PHP.

Soporte Extendido para PHP en contratos de WordPress Administrado

Nuestro equipo experto comprueba y actualiza regularmente tus páginas web con WordPress Administrado para asegurarse de que siempre son actuales y seguros. Se comprueba tanto la instalación de WordPress como la versión de PHP utilizada. Por lo tanto, no necesitas preocuparte por actualizar tu versión de PHP, pues nuestro personal experto se encarga de ello.

Sin embargo, si te contactamos con respecto al uso de una versión desactualizada de PHP o si se te ha facturado el servicio de Soporte Extendido para PHP, comprueba lo siguiente:

  • ¿Instalaste WordPress en la versión estándar? Probablemente se trate de una instalación de WordPress adicional o quizás cambiaste una instalación de WordPress Administrado a una instalación estándar.
  • ¿Configuraste un dominio o varios subdominios que no están vinculados con una instalación de WordPress Administrado, con un servicio de creación y edición de páginas web de IONOS o con un servicio externo?

Si quieres consultar en qué versión de PHP están configurados tus dominios y cómo puedes actualizar dichas versiones, dirígete a este artículo.

¿Cuándo te informamos acerca del Soporte Extendido para PHP?

IONOS te informa siempre por e-mail y con al menos 4 semanas de antelación acerca de actualizaciones de las versiones de Soporte Extendido para PHP que están a punto de publicarse. Estas notificaciones se envían a la dirección de e-mail que tienes registrada en tu perfil. Comprobar o actualizar mi dirección de e-mail

Recomendación: Puedes comprobar las notificaciones que te enviamos regularmente también desde tu cuenta IONOS al hacer clic en el símbolo de notificaciones arriba a la derecha. Comprobar notificaciones

¿Cuándo empieza el Soporte Extendido para PHP?

El servicio de Soporte Extendido para PHP empieza justo cuando dejas de recibir soporte por parte de la Comunidad PHP.

Cómo comprobar si se necesita el servicio de Soporte Extendido

Sigue los siguientes pasos:

Si todo funciona de la forma esperada, puedes cancelar el servicio de Soporte Extendido para PHP. Encontrarás una descripción con instrucciones paso a paso sobre cómo cancelar la suscripción de este servicio adicional aquí.

¿Tus scripts ya no funcionan tras la actualización?

Cambia de nuevo a la versión PHP original y ponte en contacto con un experto, por favor. Aparentemente, tu aplicación no es compatible con otra versión de PHP sin realizar cambios previos en los scripts.

¿Te gustaría adaptar tus scripts a una versión actualizada de PHP, pero necesitas más tiempo?

En primer lugar, comprueba si realmente se requiere una adaptación de los scripts. Si fuera necesaria una adaptación, ponte en contacto con nuestro Servicio de Atención al Cliente.